Problem loading/general slowness

Discussion specific to Facebook Server (eg. Guild Recruitments)

Re: Problem loading/general slowness.

Postby andrei » Fri May 10, 2013 5:25 pm

i play castle age on fb, and we had same thing happened ~2 weeks ago... total lag, cpu / mem spike, etc... here is how ca devs described and resolved the issue:

problem: *The problem is that CA currently uses old FBML to get the user profile pics. When they change that to FBs Graph it's no problem at all. Every user pic is now an IFrame which is actually a FB website in the CA website and every of that sites is loading a lot of stuff from FB, that is what makes everything so extreme slow.*

solution: *FB profile pics should now be accessed via FB graph API versus FBML. We also added in filters to restrict IOS ids from requesting FB profile pics.*

hopefully that helps a bit.

andrei
.
andrei
.
User avatar
andrei
 
Posts: 14
Joined: Mon Dec 26, 2011 11:15 pm

Re: Problem loading/general slowness

Postby admin » Fri May 10, 2013 8:23 pm

Thanks andrei. We will look into that alternative.
admin
Site Admin
 
Posts: 3376
Joined: Fri Oct 16, 2009 1:06 am

Re: Problem loading/general slowness

Postby admin » Fri May 10, 2013 8:47 pm

We have replaced the xfbml image tags (there is no mention that those were deprecated/old) with FB graph API on the home screen. Hopefully it will make things better for some of our users when the FB's client API is invoked since it won't need to parse those tags now. From our test machine there doesn't seem to be any improvement to CPU usage or memory leak however...
admin
Site Admin
 
Posts: 3376
Joined: Fri Oct 16, 2009 1:06 am

Re: Problem loading/general slowness

Postby Mutt » Fri May 10, 2013 9:34 pm

I have noticed significant performance improvements today. Thank you!
ImageImageImageImageImage
Its great being me,
Tell them Dreamworld is free!
ʇʇnW S∩ɹOqOɹO ∀ɹIſOפ
User avatar
Mutt
 
Posts: 105
Joined: Thu Nov 17, 2011 9:20 pm

Re: Problem loading/general slowness

Postby Kalon » Sat May 11, 2013 9:20 am

Congrats Playmage team! I think the problem is fixed. Thanks for the updates throughout, its really nice when devs have communication like that.
Kalon
 
Posts: 87
Joined: Wed Nov 09, 2011 9:34 am

Re: Problem loading/general slowness

Postby ianwuolle » Sun May 12, 2013 11:01 am

week and a half and still cant play dw on chrome. today cannot seem to even log onto dw with safari and firefox is annoyingly slow. hope whatever is wrong is fixed soon.
best of luck to you all
ianwuolle
 
Posts: 27
Joined: Fri Jan 27, 2012 2:20 pm

Re: Problem loading/general slowness

Postby omni » Sun May 12, 2013 1:18 pm

It's fixed for me
omni
 
Posts: 3
Joined: Thu May 02, 2013 9:33 pm

Previous

Return to Facebook Server

cron